Software and Programming: Lab 1
Introduction to Java - Using BlueJ

(Part 2)

In this lab you learn how to use BlueJ, an Integrated Development Environment (IDE) for Java and solve exercises using BlueJ or JDK.

The first two parts of this document are designed for those who may have had only minimal exposure to integrated development environments. It will also be of use to those familiar with Java Development platforms but who need to know the particulars of our setup. 
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1  Important Notes

Throughout this document you will find instructions of the form: 

Task: Now eat your hat. (A joke - do not get offended.) 

You should make sure that you do these in the order in which they appear. (But you don't need to do only these things. Feel free to experiment and explore. Nothing really bad can happen at this stage so don't worry about doing the wrong thing.) 

Many software tools use nested menus. This document (and the guide) use => to indicate choosing an option from a menu. For example, 

File=> New=> Window 

means: from the File menu, choose New; then, from the New sub-menu, choose Window. 

2  The Development Environment BlueJ

2.1  BlueJ projects

When you use BlueJ environment for development, Java programs are stored in projects. A BlueJ project is just a folder containing Java source files and class files together with other files, which are created by BlueJ. A project is created in three steps: 

1. Create a folder. 

2. Put any required files in the folder. 

3. Use BlueJ to turn the folder into a project. 

2.1.1  Creating a folder

Task: 

First create a new folder called First. Use File=> New=> Folder in the file manager to do this. 
Please note: make sure you create the folder where you want it to be; probably in your home directory (n:). Do not save your files in the default Bluej directory as they may then be deleted by other users.
Click on First. 

You should now be looking at an empty folder. 

2.1.2  Getting the required files into the First folder

Task: Open a new web browser window 

Click on the lab source files directory link (http://www.dcs.bbk.ac.uk/~gngch01/sandp1). 

You should now be looking at a list of folder names (there may only be one). 

Task: Click on the one called First. 

You should now be looking at a list of file names, some ending with the file extension .java. 

Task: Copy each of the Java files from my First folder into yours. Do this by right clicking each one in turn and selecting Save Target As. If by mistake you click on a Java file, instead of dragging it, the windowing system may open the file in a new editor window. Don't worry, just quit the editor (File=> Exit) and try again.
Please note: Make sure that the files are saved with a .java extension and not .txt or anything else; if you don't then BlueJ won't recognize the files!

2.1.3  Turn First into a BlueJ project

Now you are going to run BlueJ and turn First into a project. 

Task: Start BlueJ from the programs menu. This takes a while the first time you do it, subsequent start-up times are a lot shorter. Now select Open Non BlueJ... from the Project menu. This will pop up a file browser window which you should use to navigate to where you saved your First folder. Click once on First, then click once on the Open in BlueJ button. 

The main BlueJ window should now be displaying 2 rectangles labelled First and Second. These represent Java classes. 

To execute the class First:

Task:  Right-click on the class (the rectangle labelled First).  On the menu, choose the second item “void main(args)”.  A popup window will appear; Click OK.  

You now have the BlueJ terminal window displaying a message.  To understand the output, 

Task:  Bring the main BlueJ window back to the front and double click on the class.  You should now have a window displaying the program.  Modify the class by adding the line “System.out.println ("Welcome to the first lab!");”.

Compiling the modified program

Task: On the menu bar, click the compile button.  If there are no mistakes, you should see the message: “Class compiled – No syntax errors” appearing at the bottom of the window.  If there are mistakes, error message(s) will appear – correct them and recompile until you are successful. 

Task: Execute the program you’ve modified.  


Task: Compile and execute the program Second

Task: Now exit BlueJ using Project=> Quit. 

3 Getting Help

Whenever you're in a scheduled lab, there will be an instructor there to help you. Whenever you get stuck or want advice on how to proceed, feel free to talk to them. The instructors are there to help: ask questions early and often! 

If you have a burning reference-type question that can be answered by the Java API (Application Programming Interface) documentation, these can be found online from the module home page. 

Other help is available. The module home page provides some, and also you can navigate the Java API documentation from BlueJ: try out the Help menu in BlueJ. 

4 Exercises in BlueJ

From now on, we recommend you use BlueJ.

Exercise 1:

Exploring the behavior of a naïve ticket machine

 

Open the naive-ticket-machine (http://www.dcs.bbk.ac.uk/~gngch01/sandp1) project in BlueJ. When you create a TicketMachine instance, you will be asked to supply a number that corresponds to the price of tickets that will be issued by that particular machine. The price is taken to be a number of cents, so a positive whole number such as 500 would be appropriate as a value to work with.

 

 

1-1 Create a TicketMachine object on the object bench and take a look at its methods. You should see the following: getBalance, getPrice, insertMoney, and printTicket. Try out the getPrice method. You should see a return value containing the price of the tickets that was set when this object was created. Use the insertMoney method to simulate inserting an amount of money into the machine and then use getBalance to check that the machine has a record of the amount inserted. You can insert several separate amounts of money into the machine, just like you might insert multiple coins or notes into a real machine. Try inserting the exact amount required for a ticket. As this is a simple machine, a ticket will not be issued automatically, so once you have inserted enough money, call the printTicket method. A facsimile ticket should be printed in the BlueJ terminal window.  

1-2 Experiment with inserting different amounts of money before printing tickets. Do you notice anything strange about the machine’s behavior? What happens if you insert too much money into the machine – do you receive any refund? What happens if you do not insert enough and then try to print a ticket?

1-3 Try to obtain a good understanding of a ticket machine’s behavior by interacting with it on the object bench before we start looking at how the TicketMachine class is implemented.
Exercise 2:

For your next exercise, you will write a program that does a computation and prints out a result.   

Here are some facts: Every year, 724 billion cubic yards of water flow out of the Mississippi. There are 1760 yards in a mile. There are 365 days in a year. Here is the question: How many cubic miles of water flow out of the Mississippi every day? Some Java commands that will get the job done are: 

    double cubicYardsPerYear = 724000000000.0;

    double cubicYardsPerDay = cubicYardsPerYear / 365;

    double cubicMilesPerDay = cubicYardsPerDay / (1760*1760*1760);

    System.out.println("The answer is " + cubicMilesPerDay);

For a complete program, you have to put this inside the standard Java program wrapper: 

public class Mississippi {

   public static void main(String[] args) {

     double cubicYardsPerYear = 724000000000.0;

     double cubicYardsPerDay = cubicYardsPerYear / 365;

     double cubicMilesPerDay = cubicYardsPerDay / (1760*1760*1760);

      System.out.println("The answer is " + cubicMilesPerDay);

       }

}

This should be in a file called Mississippi.java. 

Exercise 3:
Fields, constructors, and methods

The source of most classes can be broken down into two main parts: a small outer

wrapping that simply names the class, and a much larger inner part that does all the

work. In this case, the outer wrapping appears as follows:

 

public class TicketMachine

{

Inner part of the class omitted.

}

 

The outer wrappings of different classes all look pretty much the same; their main

purpose is to provide a name for the class.

 

 

The inner part of the class is where we define the fields, constructors, and methods

that give the objects of that class their own particular characteristics and behavior. We

can summarize the essential features of those three components of a class as follows:

 

The fields store data for each object to use.

The constructors allow each object to be set up properly when it is first created.

The methods implement the behavior of the objects.

In Java, there are very few rules about the order in which you choose to define the

fields, constructors, and methods within a class. In the TicketMachine class, we have

chosen to list the fields first, the constructors second, and finally the methods 

 

  public class ClassName

  {

Fields

Constructors

Methods

  }

3-1 If the name of getBalance is changed to getAmount, does the return statement in the body of the method need to be changed, too? Try it out within BlueJ.

 

3-2 Define an accessor method, getTotal, that returns the value of the total field.

 

3-3 Try removing the return statement from the body of getPrice. What error message do you see now when you try compiling the class?

3-4 Do the insertMoney and printTicket methods have return statements? Why do you think this might be? Do you notice anything about their headers that might suggest why they do not require return statements?

Exercise 4:

Mutator methods

The get methods of a ticket machine perform similar tasks – returning the value of one of their object’s fields. The remaining methods – insertMoney and printTicket – have a much more significant role; primarily because they change the value of one or more fields of a ticket machine object each time they are called. We call methods that change the state of their object, mutator methods (or just mutators.) In the same way as we think of accessors as requests for information (questions), we can think of mutators as requests for an object to change its state.

One distinguishing effect of a mutator is that an object will often exhibit slightly different behavior before and after it is called. We can illustrate this with the following exercise.

4-1 Make a slight change to the insertMoney method via the BlueJ editor. Alter the '+=' operator to '='. Compile the class and re-run the method calls you just made on a new ticket machine. What does the balance show now? (Don’t forget to change the operator back to '+=' once you have finished.)

 

The '+=' operator is actually a short hand for the following common but more lengthy style of adding the value of an expression to a variable:

 

variable = variable + expression;

for instance:

 

balance = balance + amount;

 

4-2 Create two ticket machines with differently priced tickets. Do calls to their showPrice methods show the same output or different? How do you explain this effect?

 

4-3 What do you think would be printed if you altered the fourth statement of printTicket so that price also has quotes around it, as follows?

 

System.out.println("# " + "price" + " cents.");

 

4-4 What about the following version?

 

System.out.println("# price cents.");

 

4-5 Could either of the previous two versions be used to show the price of tickets in different ticket machines? Explain your answer.

4-6 Modify the constructor of TicketMachine so that it no longer has a parameter. Instead, the price of tickets should be fixed at 1000 cents. What effect does this have when you construct ticket machine objects within BlueJ?

 

4-7 Implement a method, empty, that simulates the effect of removing all money from the machine. This method should have a void return type, and its body should simply set the total field to zero. Does this method need to take any parameters? Test your method by creating a machine, inserting some money, printing some tickets, checking the total and then emptying the machine. Is this method a mutator or an accessor?

 

4-8 Implement a method, setPrice, that is able to set the price of tickets to a new value. The new price is passed in as a parameter value to the method. Test your method by creating a machine, showing the price of tickets, changing the price, and then showing the new price. Is this method a mutator?

 

4-9 Give the class two constructors. One should take a single parameter that specifies the price, and the other should take no parameter and set the price to be a default value of your choosing. Test your implementation by creating machines via the two different constructors.

4-10 Rewrite the printTicket method so that it declares a local variable, amountLeftToPay. This should then be initialized to contain the difference between price and balance. Rewrite the test in the conditional statement to check the value of amountLeftToPay. If its value is less than or equal to zero, a ticket should be printed, otherwise an error message should be printed stating the amount still required. Test your version to ensure that it behaves in exactly the same way as

the original version.

Exercise 5: A payroll program:

5-1 Write a program that reads two numbers from the command line, the number of hours worked by an employee and their base pay rate. Then output the total pay due.

5-2 Modify your program to meet the Department of Employment's requirement for time and a half pay for hours over forty worked in a given week.

5-3 Add warning messages to the payroll program if the pay rate is less than the minimum wage of SpiceLand (£4.25 an hour) or if the employee worked more than the maximum number of hours in a week (forty).

Exercise 6:
Many of the programs that you write in Java will depend on other classes besides those you write. For input and output in the command window, you will use the TextIO class (see the on-line text and lecture notes). 

Tip: There should be a copy of the TextIO.class file on the course web page. The simple presence of this class file allows you to use certain subroutines in any Java programs in the same directory. In particular, TextIO.getln() can be used to read in a String typed by the user, TextIO.getlnInt() can be used to read an integer number, and TextIO.getlnDouble() can be used to read in a double number. TextIO also includes the output routine TextIO.putln that you can use instead of System.out.println if you want. 

The file Converse.java contains a program that has an admittedly short and dull conversation with the user. Compile and run the program to see what it does 

/* 
   The program Converse carries on a very simple, short,  and slightly insulting conversation with the user. 

   by David Eck, September 12, 1998 
*/ 

public class Converse { 

   public static void main(String[] args) { 

      String name;         // The user's name, input by the user. 
      int favoriteNumber;  // A favorite number, input by the user. 

      TextIO.putln();  // leave a blank line 

      TextIO.putln("Hi! What's your name?");  // get user's name 
      name = TextIO.getln(); 

      TextIO.putln("What's your favorite number?");  // get user's number 
      favoriteNumber = TextIO.getlnInt(); 

      TextIO.putln("Gee, " + name + ", that's a stupid number."); 
      TextIO.putln("Where did you ever come up with " 
                           + favoriteNumber + "?"); 
      TextIO.putln("I don't want to talk anymore."); 

      TextIO.putln(); 

   } 

} // end class Converse 
  

Can you improve this program so that it has a longer conversation with the user and does some computation with the user's answers (such as asking how old the user is and computing the year in which the user was born). You don't have to do too much. Make the program several times longer than it is now. 

Exercise 7: A conversion program:

7-1 There are 2.54 centimeters to an inch. Write a program that takes a number of inches from the command line and converts it to centimeters.

7-2 Write the inverse program that reads a number of centimeters from the command line and converts it to inches.

7-3 Can you make this one program instead of two?

Exercise 8:

Here is a simple Java class. 

public class Interest { 

     /* 
        This class implements a simple program that 
        will compute the amount of interest that is 
        earned on $17,000 invested at an interest 
        rate of 0.07 for one year.  The interest and 
        the value of the investment after one year are 
        printed to standard output. 
     */ 

     public static void main(String[] args) { 

         double principal = 17000;  // the value of the investment 
         double rate = 0.07;        // the annual interest rate 
         double interest;           // interest earned in one year 

         interest = principal * rate;   // compute the interest 

         principal = principal + interest; 
               // compute value of investment after one year, with interest 
               // (Note: The new value replaces the old value of principal.) 

         System.out.print("The interest earned is $"); 
         System.out.println(interest); 
         System.out.print("The value of the investment after one year is $"); 
         System.out.println(principal); 

     } // end of main() 

 } // end of class Interest 
  

Can you tell the difference between printing statements, System.out.print and 
System.out.println, in the class Interest? 

The class Interest is provided with many comments, and you should be able to understand the meanings of all statements.

8-1 Write a program that reads an integer  n from the command line and calculates n! (n factorial, equal to 1*2*3*…*(n-1)*n).

8-2 Write a program that: 

8-2-1 Calculates and prints a multiplication table for m rows (labelled by factors 1, 2, 3,…,m) and n columns (labelled by factors 1,2,…, n). 

8-2-2 Can you transform the program to make it produce the multiplication table for numbers 4.1,4.2,…,4.9, 5.0 (rows) and 3.0,3.1,3.2,…,3.9 (columns)?

